Author Topic: error to connect to the mail server : http 1.1/401 unauthorized  (Read 7376 times)

redevil

  • Newbie
  • *
  • Posts: 1
Hi,
from yesterday I'm not able to read the mail from client.
2 days ago I changed my password as usual and also the client works fine.
But from yesterday it's not working.

I tried also to re-modify the password in the configuration of account (changing both in the manual configuration), can you help me please?

Kanku

  • Newbie
  • *
  • Posts: 2
Re: error to connect to the mail server : http 1.1/401 unauthorized
« Reply #1 on: July 20, 2017, 10:49:59 am »
Hi all,

I have the same problem  :(

rajeshwar9096

  • Newbie
  • *
  • Posts: 1
Re: error to connect to the mail server : http 1.1/401 unauthorized
« Reply #2 on: July 20, 2017, 08:44:39 pm »
I am also facing the same issue from last two days.

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12742
Re: error to connect to the mail server : http 1.1/401 unauthorized
« Reply #3 on: July 21, 2017, 08:31:09 pm »
And you guys are all from Accenture?

"http 401" means "access denied".

I'm sure the app sends the password (and the login) exactly as entered. Same as it always has.

Please ask your company's knowledgeable and friendly "computer people" if maybe, by some remote chance, they did "something" with accessing the corporate mail server through EWS (Exchange Web Services), which is what Aqua uses to connect to Exchange.

Maybe they installed a new firewall or a security appliance and broke EWS without even knowing it.

Or maybe the new VP of Corporate Security decided that the corporate mail system should only support iPhone and Outlook app, and ordered EWS (Exchange Web Services) blocked.

Or maybe some other reason I can't even imagine from where I am. The "IT department" _should_ know.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

stragglecraft

  • Newbie
  • *
  • Posts: 4
Re: error to connect to the mail server : http 1.1/401 unauthorized
« Reply #4 on: August 30, 2017, 12:14:28 am »
Try changing the user agent string to that of the outlook desktop client. Not an accenture employee.

vampywiz21

  • Newbie
  • *
  • Posts: 13
Re: error to connect to the mail server : http 1.1/401 unauthorized
« Reply #5 on: September 05, 2017, 08:46:49 pm »
I got the similar problem.

Some days ago, my company change the Exchange server from 2010 to 2016 (Office 365 business) after i got  random "http 1.1/401 unauthorized" error.

My account is working so it is not a full "access deny" thing, i got the mails, etc... only just sometimes i get this error...

What do you think , what the reason?
« Last Edit: September 05, 2017, 08:51:16 pm by vampywiz21 »

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12742
Re: error to connect to the mail server : http 1.1/401 unauthorized
« Reply #6 on: September 05, 2017, 09:04:14 pm »
@vampywiz21

Hard to say - I can only assure you that Aqua sends the exact login and password that are entered into the account's settings.

An major version switch may leave some small glitches - it's best to talk to your company's IT people about it, and mention that Aqua uses EWS (Exchange Web Services) to connect to Exchange, not ActiveSync.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

Kanku

  • Newbie
  • *
  • Posts: 2
Re: error to connect to the mail server : http 1.1/401 unauthorized
« Reply #7 on: September 06, 2017, 11:15:09 am »
Hi,

I think that the problem is that now after the migration to Outlook 2016 to connect to  https://....../ews/services.wsdl the our user\pass fails the login (I'm trying using the browser and it shows always the popup to insert the correct login).
Instead with Outlook 2013, the authorization with our credential is valid in fact I can access to WSDL through the browser.
I have just asked to IT but they don't understand the problem :-(.

Bye

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12742
Re: error to connect to the mail server : http 1.1/401 unauthorized
« Reply #8 on: September 08, 2017, 08:35:10 pm »
The standard endpoint (URL) for EWS is:

https://server/EWS/Exchagne.asmx

In Aqua you only need to enter the server, the app will add the "https://" and the "/EWS/Exchange.asmx".

Re: IT guys don't understand the problem.

Sigh. Just please tell them that you'd like to use a mail app that uses EWS (Exchange Web Services) to connect.

This is an official part of Exchange since 2007 (and still is today).
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

kafer

  • Newbie
  • *
  • Posts: 9
Re: error to connect to the mail server : http 1.1/401 unauthorized
« Reply #9 on: November 28, 2017, 03:23:31 pm »
Hi, I had the same problem and went through difficult time with corporate IT even to get listened at ( as this is not the official emal client app)
I use Aqua mail to manage and sync my Exchange company email account from my mobile. It works beautifully.
The problem arise every time (quarterly) the Company system requires me to change the Exchange account password.
After that, I update the account password onto the mobile device, and that's when the problem start.
The error 401 comes intermittently and randomly, with frequent blocks of my account on the company system, arguably for security reasons ( the sytem feels external abnormal attempt to connect to the exchange account).

I assume that the mobile Android system keep stored somewhere the old password which creates a conflict and hence either the error on the app, or the block of my company laptop account. Interestingly, the blockage or the error 401 disappear without doing nothing after some hours( I wasn't able to record times or isolate events) but than they come back.

The reason why I assume that is this while trying to fix the issue, I also installed an Android/OS sytem update which came available from the mobile manufacturer ( oneplus). Also I have deleted the account from Aqua, and reinstalled after the OS system upgrade. 

I have done nothing intentionally to fix the issue, but after the sytem upgrade, the Exchange account is working  and it's been doing that steadily for the last few hours.

Any idea where this hidden old password could be stored? Please note that before this session, I cleaned the phone cached data and the problem persisted, so should be something else.


           
« Last Edit: November 28, 2017, 04:36:58 pm by kafer »

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12742
Re: error to connect to the mail server : http 1.1/401 unauthorized
« Reply #10 on: November 28, 2017, 10:09:56 pm »
Re: I assume that the mobile Android system keep stored somewhere the old password which creates a conflict and hence either the error on the app

No. Aqua Mail is the only one storing the password and it's stored in one place, and gets updated if you go through "account setup".

Sounds to me like there is some kind of "data out of sync" at the company's Exchange server - maybe there are several of them (load balacing) and it takes time for them all to get updated with the new password.

And FWIW - I recently (a few days ago) saw same issue with my Office 365 after updating the password (policy).

It worked on one device and failed on others. I verified in the debugger that the app was sending the right password every time.

After an hour or two the errors went away and things started to work on all devices.

Never seen this before and I've used an Office 365 account since 2013 or so.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

xdealmeida

  • Newbie
  • *
  • Posts: 1
Re: error to connect to the mail server : http 1.1/401 unauthorized
« Reply #11 on: March 27, 2019, 10:53:02 pm »
Hello

I am on version 1.19.0 1434 and i can't get authenticate anymore. Last time i deleted my account and recreated and it worked. But i can't be doing so every time. I tried to contact my it but no responses.
I was desperated and a colleague told me to use the outlook app and it works perfectly.
I tried to activate the logs to share but i don't know where yo find the log Aquamail.txt file.

I tried to use OAUTH2 but no more luck.

Something is wrong in tha Aquamail app otherwise i would get the same error with Outlook app no?

Merci
Xavier

Envoyé de mon SM-G965F en utilisant Tapatalk