Author Topic: Massively high battery usage  (Read 28632 times)

thejman81

  • Newbie
  • *
  • Posts: 2
Massively high battery usage
« on: February 27, 2015, 05:11:22 am »
Hi there

Recently my HTC One M7 is getting to 20% battery after maybe 5-6 hours moderate use, previously I would get 12-15 hours. I'm not sure how long it's been happening but it seems to have gotten worse in the last 2 weeks. I was running 1.5.1.13 from Play when I noticed this. I installed 1.5.1.16.15 from the Development thread to try and fix it but there's no difference.

Looks like AquaMail is using a massive amount of battery. For the past day the two services using the most are:
- AquaMail (20% All Time, 36% Screen Off, 10% Screen On)
- Google Play services (19% All Time, 39% Screen Off, 17% Screen On)

No other app is using more than 2% Screen Off. I haven't taken much notice of battery percentages in the past, but I'm sure I haven't seen AquaMail using that much battery before.

I have 1x Exchange account, 1x Google Apps account (converted to the recently added connection method), and 2x IMAP accounts. 1x IMAP account syncs every hour, the others sync every 15 minutes. I changed those from every 10 minutes this week to save battery, but it doesn't seem to have made much difference.

Any suggestions on how to troubleshoot this? Since it's mainly Screen Off causing the problem I assume it's because of the scheduled syncs, but I need to sync at least every 15 minutes so can't disable them completely.

Thanks
Josh

thejman81

  • Newbie
  • *
  • Posts: 2
Re: Massively high battery usage
« Reply #1 on: February 27, 2015, 05:22:23 am »
Not sure if these Screen Off stats over the same period help to suggest where the problem could be?
CPU total - 5m 5s
CPU foreground - 3s
Keep awake - 8m 32s
Mobile data received - 309KB
Mobile data sent - 57.92
Wi-Fi data received - 4.02MB
Wi-Fi data sent - 648KB

Thanks
Josh

Kostya Vasilyev, Aqua Mail

  • Administrator
  • Hero Member
  • *****
  • Posts: 12794
Re: Massively high battery usage
« Reply #2 on: March 01, 2015, 01:45:42 am »
If those are stats for Aqua:

Quote
CPU total - 5m 5s
CPU foreground - 3s
Keep awake - 8m 32s

I'd say it's not bad -- 8.5 minutes of "keep awake" time over what, 5-6 hours? Just two minutes an hour, or about 30 seconds per each mail check (every 15 minutes, even if that's not all of your accounts).

And definitely 8-9 minutes of "keep awake" should not be getting your phone from 100% charge to 20% in 5-6 hours.

Don't know what "screen off" vs "screen on" refer to -- must be something specific to your device's system software -- but I assume it's the app's battery use further broken down to when the screen is off vs. on. It's natural that the "screen off" portion would be larger.

What are the detailed stats for Google Play Services? What about other apps listed on that battery screen?

On my LG G3, before it got 5.0, I would get about 30% battery use by "Android OS" and "Android System", IIRC (and nothing like that on other phones wht 4.2-4.4)...

Sorry I didn't just go "aha, it's that checkbox over there, turn it off", but... the "keep awake" really does look quite reasonable.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

freeman1975

  • Newbie
  • *
  • Posts: 16
Re: Massively high battery usage
« Reply #3 on: March 03, 2015, 09:22:57 pm »
Hi everyone and greetings to the developer of such an amazing email client :-)
First post here.

I'd like to confirm the same behavior of Aquamail on my phone (Moto g 2013, Lollipop 5.0.2). In my case, the high battery drain happens *only* when I'm using my mobile data, and not on wifi. The statistics in the "battery" section, after a couple of hours in H+, read:

 - Keep Awake 7m 18s
 - Mobile radio active 52m 35s <---- This looks strange to me

I'm pretty sure that the "mobile data" is the  problem. Maybe it's not directly Aquamail to blame, but Lollipop, or some strange interaction between them.
For the moment, I disabled the "Check for connection" checkbox in the "Network" settings of Aquamail. Will report if this helps.

Thank you in advance.

E.
« Last Edit: March 03, 2015, 09:31:14 pm by freeman1975 »

Paris Geek

  • Hero Member
  • *****
  • Posts: 2967
Re: Massively high battery usage
« Reply #4 on: March 04, 2015, 09:00:47 am »
Hi everyone and greetings to the developer of such an amazing email client :-)
First post here.

I'd like to confirm the same behavior of Aquamail on my phone (Moto g 2013, Lollipop 5.0.2). In my case, the high battery drain happens *only* when I'm using my mobile data, and not on wifi. The statistics in the "battery" section, after a couple of hours in H+, read:

 - Keep Awake 7m 18s
 - Mobile radio active 52m 35s <---- This looks strange to me

I'm pretty sure that the "mobile data" is the  problem. Maybe it's not directly Aquamail to blame, but Lollipop, or some strange interaction between them.
For the moment, I disabled the "Check for connection" checkbox in the "Network" settings of Aquamail. Will report if this helps.

Thank you in advance.

E.

With you configuration, if you can stand 7-8 hours without needing to charge your battery, that's correct. Don't expect better autonomy...

freeman1975

  • Newbie
  • *
  • Posts: 16
Re: Massively high battery usage
« Reply #5 on: March 04, 2015, 03:28:06 pm »
With you configuration, if you can stand 7-8 hours without needing to charge your battery, that's correct. Don't expect better autonomy...

Could you please elaborate a bit on this? What do you mean by "my configuration"? Please note that I didn't face the problem before upgrading to LP.

Paris Geek

  • Hero Member
  • *****
  • Posts: 2967
Re: Massively high battery usage
« Reply #6 on: March 04, 2015, 06:10:00 pm »
With you configuration, if you can stand 7-8 hours without needing to charge your battery, that's correct. Don't expect better autonomy...

Could you please elaborate a bit on this? What do you mean by "my configuration"? Please note that I didn't face the problem before upgrading to LP.
Your configuration = (Moto g 2013, Lollipop 5.0.2, H+). If you get 7-8 hours of autonomy, that's good. What do you expect from a 2 years old battery, a smartphone not necesseraly optimised to Lollipop, having to connect to a mobile radio network?
« Last Edit: March 04, 2015, 06:12:22 pm by Paris Geek »

Kostya Vasilyev, Aqua Mail

  • Administrator
  • Hero Member
  • *****
  • Posts: 12794
Re: Massively high battery usage
« Reply #7 on: March 04, 2015, 11:24:45 pm »
This "mobile radio" thing is new in 5.0, and can happen with pretty much any app that uses networking.

http://www.reddit.com/r/Android/comments/2mz5aa/lollipop_battery_drain_is_caused_by_mobile_radio

"Lollipop battery drain is caused by mobile radio active on every app you use."

http://www.reddit.com/r/Nexus5/comments/2usuyn/mobile_radio_active/

"this is just beyond frustrating"

https://productforums.google.com/forum/#!topic/nexus/jD1xCGegQg8%5B1-25%5D

more of the same

Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

freeman1975

  • Newbie
  • *
  • Posts: 16
Re: Massively high battery usage
« Reply #8 on: March 05, 2015, 01:30:01 am »

Your configuration = (Moto g 2013, Lollipop 5.0.2, H+). If you get 7-8 hours of autonomy, that's good. What do you expect from a 2 years old battery, a smartphone not necesseraly optimised to Lollipop, having to connect to a mobile radio network?

Wrong. I can do almost 2 days with a single charge.

freeman1975

  • Newbie
  • *
  • Posts: 16
Re: Massively high battery usage
« Reply #9 on: March 05, 2015, 01:32:14 am »
This "mobile radio" thing is new in 5.0, and can happen with pretty much any app that uses networking.

http://www.reddit.com/r/Android/comments/2mz5aa/lollipop_battery_drain_is_caused_by_mobile_radio [nofollow]

"Lollipop battery drain is caused by mobile radio active on every app you use."

http://www.reddit.com/r/Nexus5/comments/2usuyn/mobile_radio_active/ [nofollow]

"this is just beyond frustrating"

https://productforums.google.com/forum/#!topic/nexus/jD1xCGegQg8%5B1-25%5D [nofollow]

more of the same

Well, as I said in may post, it could also be a Lollipop bug.. From an user's point of view, I can only judge from the program listed under the "Battery" menu. That's why I'm here.
I

Kostya Vasilyev, Aqua Mail

  • Administrator
  • Hero Member
  • *****
  • Posts: 12794
Re: Massively high battery usage
« Reply #10 on: March 05, 2015, 09:05:59 pm »
I am quite sure it is a Lollipop bug, that's why I posted those links, where the discussions mention all kinds of other apps...

I believe (from Android news sites) that Google is aware of it, but so far, it looks like there is no fix -- e.g. the latest Lollipop build for Nexus 5 is 5.0.1, and it's quite old.

Maybe it's something in Qualcomm's mobile drivers, or how Android and those drivers interact, whatever...

As far I'm concerned -- I'm not aware of any workaround unless you want Aqua to stop doing anything with mobile data, and then you might as well turn off mobile data in the device's system settings. Not very useful.

Something more constructive would have to come out of Google.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

freeman1975

  • Newbie
  • *
  • Posts: 16
Re: Massively high battery usage
« Reply #11 on: March 06, 2015, 12:05:25 am »
I am quite sure it is a Lollipop bug, that's why I posted those links, where the discussions mention all kinds of other apps...

I believe (from Android news sites) that Google is aware of it, but so far, it looks like there is no fix -- e.g. the latest Lollipop build for Nexus 5 is 5.0.1, and it's quite old.

Maybe it's something in Qualcomm's mobile drivers, or how Android and those drivers interact, whatever...

As far I'm concerned -- I'm not aware of any workaround unless you want Aqua to stop doing anything with mobile data, and then you might as well turn off mobile data in the device's system settings. Not very useful.

Something more constructive would have to come out of Google.

I don't know what is causing the problem. For sure, the "bug" doesn't show up on KK. So it's likely due to LP upgrade
For the moment, I tried to deny AM the "Keep awake" permission, by means of "App Ops". Will see if things get better. In the meanwhile I'll continue to enjoy this amazing email client ;-)

Thank you for the feedback.

E.

Kostya Vasilyev, Aqua Mail

  • Administrator
  • Hero Member
  • *****
  • Posts: 12794
Re: Massively high battery usage
« Reply #12 on: March 06, 2015, 12:44:26 am »
Yes, as I wrote above, the "mobile data" battery metric is all new in LP, did not exist in KK.

And the bug is new too.

As far as wake locks go -- Aqua always keeps a wake lock when it's doing something (working with the network) -- and I've seen a "battery use" screenshot where for AquaMail, "mobile data" was in the hours and "keep awake" was in the minutes.

So there is a large disconnect in numbers right there. Because Aqua keeps a wake lock when it's working with the network, the "keep awake" cannot be higher than "mobile data". And yet it was.

I *think* that LP tries to put the modem into some sort of low-power state, and it gets "stuck" in some sense.

Oh, and I would try rebooting the phone too, maybe that will reset things.

Meanwhile, I'm keeping my fingers crossed for Android 5.1, supposedly to come fairly soon.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

Kostya Vasilyev, Aqua Mail

  • Administrator
  • Hero Member
  • *****
  • Posts: 12794
Re: Massively high battery usage
« Reply #13 on: March 06, 2015, 12:56:05 am »
http://www.loadthegame.com/2015/01/22/moto-g-2014-bugs-caused-android-lollipop-will-continue-issue-longer/

Quote
The Moto G 2014 and a whole bunch of other devices have been suffering from various issues ever since [...] Android 5.0 Lollipop. Among these problems, we find the already infamous memory leak bug and battery drain issues, which only became more widespread and complemented by other issues with the release on Android 5.0.1 Lollipop.

Many users were hoping that Android 5.0.2 Lollipop would be able to fix this problem, but as it turns out, the update only includes some minor fixes for internal alarms and storage management. Google seems to be aware of these issues and is said to be working on a new update as we speak
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

mikeone

  • Hero Member
  • *****
  • Posts: 2625
Re: Massively high battery usage
« Reply #14 on: March 11, 2015, 12:15:08 am »
...
Meanwhile, I'm keeping my fingers crossed for Android 5.1, supposedly to come fairly soon.

http://officialandroid.blogspot.de/2015/03/android-51-unwrapping-new-lollipop.html?m=1

Quote

Monday, March 9, 2015
Android 5.1: Unwrapping a new Lollipop update

Today we are rolling out Android 5.1 - an update to Lollipop that improves stability and performance and offers a few new features...
[Unquote]
« Last Edit: March 11, 2015, 12:19:17 am by mikeone »