Author Topic: missing messages  (Read 6895 times)

stehbar

  • Newbie
  • *
  • Posts: 2
missing messages
« on: November 29, 2012, 10:43:12 pm »
Hi there! I have a (possibly silly) question that I was not able to answer googling around. All the imap clients I have tried on my nexus 7 tablet running android 4.2 (the native application, aquamail, and k9) seem to randomly (but systematically) miss several messages present on the server, and regularly visible both with the mail client on a mac, or using my corporate webmail interface. I am an android newbie, and I am wondering if there is anything trivial I may be overlooking. Many thanks for the advice and help anybody can give me. Stefano

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12742
Re: missing messages
« Reply #1 on: November 30, 2012, 02:38:19 am »
Can't speak for "all imap clients", but mine loads N most recent messages from the server, and relies on message numbers for this.

Per the IMAP spec, the server is supposed to assign those numbers in order, but I've seen some that don't adhere to the IMAP spec.

Desktop mail apps have the luxury of being able to list all messages on the server, so they never miss anything.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

stehbar

  • Newbie
  • *
  • Posts: 2
Re: missing messages
« Reply #2 on: November 30, 2012, 09:40:50 am »
Thanks. Is there a way I, as a user, can inspect the message numbers so that I can report to the system administrator? SB

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12742
Re: missing messages
« Reply #3 on: December 01, 2012, 12:45:46 am »
You can use my app's message order test (long press the account, choose last item), then instead of sending it to me, send it to yourself to get the file or the admin.

The IMAP spec is RFC 3501, easy to Google for.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

mikecallaghan

  • Newbie
  • *
  • Posts: 5
Re: missing messages
« Reply #4 on: January 02, 2013, 03:13:44 am »

This is interesting, because I just sent you a message about the same thing happening in POP3.
Large numbers of the server's messages weren't getting to my Nexus 7, regardless of which Email app I was using on the tablet.  The server is running Mercury mail.  I did find very long connect times on the server logs. 100's of seconds in some csases, even though Aquamail was connecting for just a second or two.  The Nexus is running the latest Android, although the problem existed with earlier ones.

I finally found that changing the 'Server Delete Compatibility' setting from 'Shared Session' to
'New Session' seemed to fix the issue.  I have no idea why.   I do hope this was the right thing to do, and that the problem is truly behind me.

Mike