Author Topic: POP3 Server Delete Compatibilitly  (Read 1357 times)

phred

  • Sr. Member
  • ****
  • Posts: 359
POP3 Server Delete Compatibilitly
« on: December 08, 2021, 09:02:42 pm »
Hi...

Under an account's POP3 settings, there is an option for Server Delete Compatibility. What exactly does this do?
I'm using this with a GMail account that is configured for POP3 on the server side and do not want to delete or mark as read, the messages (on the server.)

AquaMail is receiving the email, but my desktop, stand-alone email client is not. I need to received them on both my both and my desktop, which is the reason I have the messages left on the server.

Thanks.

EDIT: Fixed typos for clarification
« Last Edit: December 10, 2021, 10:47:55 pm by phred »

phred

  • Sr. Member
  • ****
  • Posts: 359
Re: POP3 Server Delete Compatibilitly
« Reply #1 on: December 10, 2021, 03:48:54 pm »
Bump

Justin

  • Sr. Member
  • ****
  • Posts: 298
Re: POP3 Server Delete Compatibilitly
« Reply #2 on: December 10, 2021, 09:31:57 pm »
@phred You will have to set this behavior also in Gmail settings in web interface. Settings > Forwarding and Pop/IMAP

BTW: Why not using IMAP?

phred

  • Sr. Member
  • ****
  • Posts: 359
Re: POP3 Server Delete Compatibilitly
« Reply #3 on: December 10, 2021, 11:02:25 pm »
@Justin-

I'm trying to preserve the messages on the server until I have been able to read them on my desktop PC using a stand-alone mail client. But I want to see them (on my phone) if I'm not at the PC.

It seems that with IMAP, once they're read in AM, they're marked as read on the server and then my mail client doesn't pick them up. Is there a way to accomplish this with IMAP and GMail. I have IMAP working like this on my non-GMail accounts. I -thought- I had it configured properly on GMail's server in the Forwarding and POP/IMAP section. Perhaps I'll give it another try over the weekend.

But my initial question relates to the POP3 setting Server Delete Compatibility in AM. There are two options within as they both look like they delete the message. Either as soon as it's read or the next time mail is checked. I don't want the messages deleted until I say so.

Thanks.

Justin

  • Sr. Member
  • ****
  • Posts: 298
Re: POP3 Server Delete Compatibilitly
« Reply #4 on: December 11, 2021, 11:13:05 am »
As I said before, you will have to set it for POP in Gmail settings in webinterface.

The other point:
If you use IMAP., you will have all mails on all devices, even sent ones.
Additionally there is a setting in AquaMail not to mark messages as read.

phred

  • Sr. Member
  • ****
  • Posts: 359
Re: POP3 Server Delete Compatibilitly
« Reply #5 on: December 11, 2021, 07:26:15 pm »
If you use IMAP., you will have all mails on all devices, even sent ones.
Additionally there is a setting in AquaMail not to mark messages as read.
Yes, that's the way it works with all my non-Gmail accounts. Don't know why it wasn't working like this on this one, but I will try again later today and report back.


Martin, Aqua Mail Support

  • Global Moderator
  • Full Member
  • *****
  • Posts: 143
Re: POP3 Server Delete Compatibilitly
« Reply #6 on: December 15, 2021, 10:10:50 am »
Hey phred,

The Server Delete Compatibility option isn't automatic deletion and can't prevent your desktop PC from downloading the messages. It's an instruction when Aqua Mail will actually delete the mail from the server, after you have manually specified a message for permanent deletion. The options boil down to whether the app starts a new session (more data usage) or uses the next sync session to also perform the deletion operation on the server. The option won't come into play, as long as you don't permanently delete something yourself.

As Justin said, IMAP is better for your use case and you can set Aqua Mail up to not mark messages read when viewing. You should also use IMAP on the PC if going that route.

Martin

phred

  • Sr. Member
  • ****
  • Posts: 359
Re: POP3 Server Delete Compatibilitly
« Reply #7 on: December 15, 2021, 04:36:53 pm »
Thanks for the explanation, Martin.

I've now got it set up using IMAP and it's working as expected.