Author Topic: AM no longer syncs as scheduled after transfer from Adroid 5 phone to Adroid 11  (Read 442 times)

insession

  • Newbie
  • *
  • Posts: 11
Downloaded paid pro app from play store on new phone (Nokia XR20), imported all settings from previous install backup on old Android 5 phone.
All is well, except it now syncs somewhat randomly, and certainly not on schedule.
Sometimes for a half hour or more, no sync. Manual sync always works.
See attached screenshots for pre-emptive answers to what my settings are.
"System Settings" Dialog: doesn't seem to matter which of the three options I pick.

Appreciate a solution ;-)

Peter

chris122380

  • Full Member
  • ***
  • Posts: 119
Have you turned off battery optimization for AquaMail?


insession

  • Newbie
  • *
  • Posts: 11
yes, sorry, forgot to mention that battery optimization for AquaMail is set to 'not optimized'

Martin, Aqua Mail Support

  • Global Moderator
  • Jr. Member
  • *****
  • Posts: 80
You should check in Android Settings > Apps > Aqua Mail > Data if the app is consuming any background data. If it's not, the "not optimized" setting isn't working correctly and Aqua Mail is still killed. For that, you can try to pin the app in recent apps (square or swipe up + hold > tap and hold the app window > padlock icon).

I'd also recommend not using 5000 sync and 250 cache - you only get to keep 250 when the app cleans up mail outside of the cache limit every 12hrs. Also, the 3 minute sync interval has since been removed - I suppose you're only able to set it via the backup file. The current minimum is 5, which you should try to set, just in case that's a problem. It should not matter much what your sync interval is due to push mail.

insession

  • Newbie
  • *
  • Posts: 11
Thanks Martin!
See screenshot re: background data.
I've changed the custom check interval and the 5000 sync per your advice. Fyi, I did have it on 3min because some of my accounts are POP still.
Will report if this solves it. If I don't report it solved, then it's still an issue ;-)

Peter

insession

  • Newbie
  • *
  • Posts: 11
After having made the suggested changes, I can report no change. I was out and about, and it didn't sync for 1.5 hours. Then I hopped on a wifi network somewhere, and voila, it synced. Mentioning this in case it triggers any insights ;-)
However, at home I'm always on wifi, and there too it hasn't synced at the designated intervals.
Just tried it again at home, sent myself an email, waited 9 minutes, no check/sync. Sync interval in AM is set at 5min.

Martin, Aqua Mail Support

  • Global Moderator
  • Jr. Member
  • *****
  • Posts: 80
Can you send us a log file at support@aqua-mail.com during which:
1. You send an e-mail to an address that is added in the app.
2. A sync event should occur (so the log needs to last more than 5 minutes).

In addition to that, I'd still recommend pinning Aqua Mail to recent apps, at least to test if that has any effect. You should also make sure your system notification settings are enabled and configured as you want to see them.

Martin

insession

  • Newbie
  • *
  • Posts: 11
Thanks Martin. Haven't sent log files before - can you specify in the attached screenshot what settings you need checked?
Sending an email to an address which I manually input in the To field?
Where do I set the log to last >5min?

Also, I'll pin as per your suggestion, however I can't use any other apps while it's pinned it seems.
System notification settings, to the best of my knowledge, are as I want them to me. If you've got additional pointers there, I'd appreciate it.

Peter

insession

  • Newbie
  • *
  • Posts: 11
Just another update. Phone on airplane mode all night, turn off airplane mode in the AM, whatsapp and text syn within seconds, AM not for 15 min at all. I then initiate manual sync, which works fine.

Just reporting...

insession

  • Newbie
  • *
  • Posts: 11
Martin - sent you a log report as requested. Let me know if it's what you were looking for.

Peter