Author Topic: Avoiding "on behalf of" when sending email using an alias  (Read 306 times)

darkoroje

  • Newbie
  • *
  • Posts: 2
Avoiding "on behalf of" when sending email using an alias
« on: September 23, 2021, 01:59:04 pm »
Hello,

I have set up an alias email address for my gmail address in AqualMail. However, when I send emails using that alias, the recepient still sees my gmail address followed by alias as a sender - e.g. "user@gmail.com on behalf of alias@mycustomemail.com" which defeates the purpose of having the alias in the first place. Is there a way to fix this?

"alias@mycustomemail.com" is actually my custom email address and domain and I have it set up as an addtional email address in gmail as well. When I use gmail for android to send emails, only "alias@mycustomemail.com" is visible as the sender.

Thanks.

Justin

  • Sr. Member
  • ****
  • Posts: 271
Re: Avoiding "on behalf of" when sending email using an alias
« Reply #1 on: September 23, 2021, 03:55:54 pm »
You have set this alias address before in Gmail settings in web access?

darkoroje

  • Newbie
  • *
  • Posts: 2
Re: Avoiding "on behalf of" when sending email using an alias
« Reply #2 on: September 23, 2021, 04:04:34 pm »
Not really shure what you are asking, but I have added the alias address to the "Accounts and Import" part of setting in the GMail Web interface. It works perfectly with the GMail Android App.

Thanks.

Justin

  • Sr. Member
  • ****
  • Posts: 271
Re: Avoiding "on behalf of" when sending email using an alias
« Reply #3 on: September 23, 2021, 09:56:22 pm »
Yes, this is what I wrote.

Did you try to disable the "Alias" checkbox in Web interface?

BTW: I have 9 aliases in Gmail, never seen "on behalf of" (nor the recipients), when writing in AquaMail or ajy other client.
« Last Edit: September 23, 2021, 09:58:30 pm by Justin »