Author Topic: Yahoo mail and Greek characters - strict mime  (Read 139 times)

nikant

  • Newbie
  • *
  • Posts: 5
Yahoo mail and Greek characters - strict mime
« on: September 11, 2019, 07:53:19 am »
Hi,

looking for a solution that usually appears as a problem in Thunderbird but now I have it in Aquamail too.

When composing and sending a message in Greek the receiver gets instead of the mail body a string of question marks (??????????????)

- Aquamail Pro in Android
- Greek characters in title appear correctly
- UTF-8 is turned ON
- in Thunderbird the solution was to set a config option "mail.strictly_mime" to ON in order to solve this (read here: can't post link, but you can search "yahoo Greek question marks Thunderbird" )


any ideas how to solve this?

Thank you

patrickdrd

  • Full Member
  • ***
  • Posts: 131
Re: Yahoo mail and Greek characters - strict mime
« Reply #1 on: September 11, 2019, 01:49:58 pm »
wow, that's a good one, but I don't think you'll find an answer,
I had many such emails (in thunderbird), but older ones (from 10-15 years back) and from two users only (!),
I didn't know that solution, and I can't check now because I ran a maintenance and deleted those old mails,
I'm using gmail lately (after the yahoo hack, etc, it supports push too in aquamail) but I hope you'll find a solution

nikant

  • Newbie
  • *
  • Posts: 5
Re: Yahoo mail and Greek characters - strict mime
« Reply #2 on: September 11, 2019, 03:46:11 pm »
wow, that's a good one, but I don't think you'll find an answer,
I had many such emails (in thunderbird), but older ones (from 10-15 years back) and from two users only (!),
I didn't know that solution, and I can't check now because I ran a maintenance and deleted those old mails,
I'm using gmail lately (after the yahoo hack, etc, it supports push too in aquamail) but I hope you'll find a solution

Finding an answer is on the creators of AquaMail if they decide to respond to this I guess

This is not an old matter. It is active and continuously producing problems (i.e. on Thunderbird) and has to do with Yahoo's problematic server response. I can't go into details since I do not know them but if solutions in tech level exist and they are explained in Thunderbird bug reports if someone searches

Still it is a shame if this not fixed or there should be a notice in AquaMail that it does not work correctly with Yahoo for languages other than English

phred

  • Full Member
  • ***
  • Posts: 212
Re: Yahoo mail and Greek characters - strict mime
« Reply #3 on: September 11, 2019, 10:54:54 pm »
Finding an answer is on the creators of AquaMail if they decide to respond to this I guess

This is not an old matter. It is active and continuously producing problems (i.e. on Thunderbird) and has to do with Yahoo's problematic server response. I can't go into details since I do not know them but if solutions in tech level exist and they are explained in Thunderbird bug reports if someone searches
I may be misunderstanding you, but why do you expect AM to fix a problem that is on Yahoo's side? If the issue also happens on Thunderbird, then it's Yahoo's problem, not AM's or TBird's.

And if you found technical solutions on TBird's site, then common courtesy would be for you to link them here.

nikant

  • Newbie
  • *
  • Posts: 5
Re: Yahoo mail and Greek characters - strict mime
« Reply #4 on: September 12, 2019, 07:56:49 am »
And if you found technical solutions on TBird's site, then common courtesy would be for you to link them here.
... aaand after 20something years of being online and admin in three forums here comes Phred.
Thank you Phred for pointing common courtesy to me. Allow me to explain: Because I am a new member on this forum I am not yet allowed to post external links


Now can we be friends Phred?


I may be misunderstanding you, but why do you expect AM to fix a problem that is on Yahoo's side? If the issue also happens on Thunderbird, then it's Yahoo's problem, not AM's or TBird's.

"problem on Yahoo's side" is one way of looking at it. Admins configure servers in various ways because they want to. So in Yahoo's point maybe they are not doing something wrong.
For example I personally had problem with a server that had a problem with the following:

Content-Type: text/plain; charset="UTF-8"

and yet it accepted this:

Content-Type: text/plain; charset=UTF-8


What can I say. S**t happens.

I came here seeking a solution not demanding anything. And Yes TB has this option to solve this even if it's free and open-source. So maybe, and without any disrespect, a paid app like AM should make an option available to solve this OR it could write in the FAQ or in Play Store something like: "if you wanna write Greek (and other langs I guess) with Yahoo mail please know that you can't!"

Either would be acceptable, by me at least



« Last Edit: September 12, 2019, 08:13:42 am by nikant »

nikant

  • Newbie
  • *
  • Posts: 5
Re: Yahoo mail and Greek characters - strict mime
« Reply #5 on: September 12, 2019, 07:58:46 am »
and although I am not allowed yet to post links here are two to get you started:

https://    support.mozilla.org/en-US/questions/1206354

https://    bugzilla.mozilla.org/show_bug.cgi?id=1435903

Re: Yahoo mail and Greek characters - strict mime
« Reply #6 on: September 12, 2019, 01:51:22 pm »
Hi,

We've another user that contacted us about this via email. We're also looking into a stable solution. Please capture your actions in a log and forward it at support@aqua-mail.com. What we need you to do exactly us:
1. Tap the compose button
2. Compose a message in Greek
3. Send it
4. Confirm that he message on the receiving side is wrongly displayed
5. Then forward the log

How to create and forward a log:
http://bit.do/e8nEB

Hi,

looking for a solution that usually appears as a problem in Thunderbird but now I have it in Aquamail too.

When composing and sending a message in Greek the receiver gets instead of the mail body a string of question marks (??????????????)

- Aquamail Pro in Android
- Greek characters in title appear correctly
- UTF-8 is turned ON
- in Thunderbird the solution was to set a config option "mail.strictly_mime" to ON in order to solve this (read here: can't post link, but you can search "yahoo Greek question marks Thunderbird" )


any ideas how to solve this?

Thank you

nikant

  • Newbie
  • *
  • Posts: 5
Re: Yahoo mail and Greek characters - strict mime
« Reply #7 on: September 12, 2019, 02:16:17 pm »
Hi,

We've another user that contacted us about this via email. We're also looking into a stable solution. Please capture your actions in a log and forward it at support@aqua-mail.com. What we need you to do exactly us:
............

Thank you

I will send all details