Author Topic: Office365 - nothing happens after authentication  (Read 372 times)

leobor

  • Newbie
  • *
  • Posts: 4
Office365 - nothing happens after authentication
« on: November 25, 2018, 02:40:14 pm »
My corporate mail move to another domain on Office365. I am able to access mail from the browser but not from Aquamail. I pass authentication successfully but then nothing happens, screen blank and new account not added. What to do? Is there a log to see what actually happened?

P.S. Microsoft Outlook app works fine. I just do not want to use it.
« Last Edit: November 26, 2018, 03:08:03 pm by leobor »

Nadejda Fudulska, MobiSystems, AquaMail support

  • Global Moderator
  • Full Member
  • *****
  • Posts: 159
    • MobiSystems
Re: Office365 - nothing happens after authentication
« Reply #1 on: November 26, 2018, 06:33:12 pm »
Hi,

Do you get any error messages? If yes, what are they?

There are different ways to connect to Exchange - most but not all apps (including Gmail app and stock Email app) use something called ActiveSync.
Aqua (and other apps, for Android and Windows even) - use something called EWS (Exchange Web Services).
EWS is official, supported by Microsoft since 2007 - but may have been turned off on your server by your server admins, or may require different server settings.

So, please ask your company's "computer people" about EWS (Exchange Web Services) specifically.
- Is this enabled on the server, or restricted somehow?

- If enabled, what are the settings (server name, login)?

- And then you can use the Manual button (after entering your email and password) in Aqua Mail and make sure you're using those settings.

For further questions, please contact us at support@aqua-mail.com

Thank you!

leobor

  • Newbie
  • *
  • Posts: 4
Re: Office365 - nothing happens after authentication
« Reply #2 on: November 26, 2018, 06:36:42 pm »
No error messages - just blank screen. This is why I asked about Aquamail log file if exists.
Not sure I can find out about EWS settings as I work for a huge company. Can I check this myself somehow?

leobor

  • Newbie
  • *
  • Posts: 4
Re: Office365 - nothing happens after authentication
« Reply #3 on: November 27, 2018, 02:56:36 pm »
Went to check if EWS is enabled for our company. It seems to be on:

Applications that leverage EWS should always use Autodiscover to determine the best Exchange client access server to connect to. The use of Autodiscover will guarantee that the code connects to a client access server of the correct version in the correct active directory site for the mailbox in question.

Applications should never hard code the EWS url to a static value. Doing so could result in unexpected code failures during future mailbox moves, upgrades or system maintenance.


You mentioned using manual setup - I chose Office 365 in the account wizard and haven't seen manual option. In any case, it is outlook.office365.com which is standard.

plsfixit

  • Newbie
  • *
  • Posts: 1
Re: Office365 - nothing happens after authentication
« Reply #4 on: December 07, 2018, 04:27:39 pm »
Hey There!

I've actually initially bought aquamail so I could set it up with my 2 different company (exchange) mail accounts. However as I'm a contractor I'm using my own personal mobile phone: hence I do not want to get their crappy policies anywhere near my stuff :).
As a result: I wouldnt like to install intune as an enforcer etc.

The only thing restricting me is the user agent popping up in the webview.
Would it be possible to
 - expose an addon that could modify this?
 - add a customization option (maybe under debug?).
my life would be soo much easier if I could change the string Android to Linux.
It works like a charm in the firefox browser.. but.. I see aquamail and how great it is, but I cant use it because of this..

Thanks very much for reading this  & your consideration..
Have a nice day & keep up the good work :)