Author Topic: Version 1.17.0-1306 - notifications not working  (Read 6320 times)

icsterm

  • Newbie
  • *
  • Posts: 6
Version 1.17.0-1306 - notifications not working
« on: October 12, 2018, 10:59:42 pm »
The updated version in the subject caused my 6 months old Aquamail install (with many updates which ran smoothly untill now) to fail notifying me of new unread e-mails, there is no new notification in the drawer despite push e-mail working fine (new emails are received instantly all the time, but I lack notifications).
Running MIUI 9 on my Redmi Note 4 and the issue occured minutes after updating, I usually receive a lot of e-mails daily and I missed some work related messages.

I checked Aquamail settings and message notifications are enabled globally, account special settings are disabled. All Android related permisions are enabled (notification permisions too). The main Aquamail notification is working(the one that keeps the app in memory and says push mode activated), but no new mail notifications are spawned at all.

How can I send logs? I rebooted my phone, haven't updated my phone with new Android OTA's so that's not the culprit.
I even reinstalled Aquamail and imported backup but still notifications not coming in.

Can I make a screen recorded video and post a youtube link describing the issue in <1min video?
« Last Edit: October 12, 2018, 11:07:13 pm by icsterm »

mikeone

  • Hero Member
  • *****
  • Posts: 2762
Re: Version 1.17.0-1306 - notifications not working
« Reply #1 on: October 12, 2018, 11:41:28 pm »
Creating a log if something doesn’t work right:

https://www.aqua-mail.com/troubleshooting/

icsterm

  • Newbie
  • *
  • Posts: 6
Re: Version 1.17.0-1306 - notifications not working
« Reply #2 on: October 13, 2018, 09:43:49 pm »
I fixed my issue, the new update brought some new design for android 7+ and it can't reference files as notification sound any longer.
So by choosing a system ringtone instead of a local mp3 file the issue was fixed.

poedel

  • Newbie
  • *
  • Posts: 1
Re: Version 1.17.0-1306 - notifications not working
« Reply #3 on: October 14, 2018, 11:03:31 am »
I fixed my issue, the new update brought some new design for android 7+ and it can't reference files as notification sound any longer.
So by choosing a system ringtone instead of a local mp3 file the issue was fixed.
I got the same problem, but I do not want to use a system sound but different sounds for each account to hear while incoming if it is an important account that needs immediate checking.
I hope that will get fixed soon as it's still a feature to use your own sounds for each account.

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: Version 1.17.0-1306 - notifications not working
« Reply #4 on: October 15, 2018, 12:20:46 pm »
Quote
I got the same problem, but I do not want to use a system sound but different sounds for each account to hear while incoming if it is an important account that needs immediate checking.

No it won't be "fixed".

The "change" has to do with something Google is forcing us - and all other app developers - to do.

The effect on notifications is completely "unexpected" and probably "unintended" but it's too late now, nobody's going to fix any already released Android versions.

( this may still work in an app that's not been updated yet to Google's latest requirements - but all apps will need to be updated very soon )

Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: Version 1.17.0-1306 - notifications not working
« Reply #5 on: October 15, 2018, 12:31:50 pm »
It's this change in Android 7.0 that we were required to "accept":

https://developer.android.com/about/versions/nougat/android-7.0-changes#sharing-files

It affects opening attachments (which still works, fortunately :) ) but also affected notifications (I was quite surprised).

In this version:

https://www.aqua-mail.com/staging/AquaMail-market-1.17.0-1315-stable-5b6774cc4fb0.apk

Notifications do work again but Android ignores my attempts to "attach" the sound even if it's done "the new proper 7.0 way".
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

icsterm

  • Newbie
  • *
  • Posts: 6
Re: Version 1.17.0-1306 - notifications not working
« Reply #6 on: October 15, 2018, 12:34:41 pm »
Maybe create a way for aquamail to import the custom sound file in it's private storage, so it will access it properly and display notifications with any user sound file. There should be workarounds, I find it a bit silly to have this forced downgrade just because Google wants this change.
I personally don't find this issue something that is deal changing, but it's not impossible to come with a workaround.
« Last Edit: October 15, 2018, 12:36:56 pm by icsterm »

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: Version 1.17.0-1306 - notifications not working
« Reply #7 on: October 15, 2018, 12:38:50 pm »
The problem is we can't use a FILE when specifying a notification sound.

I already have tried a content:// URI and Android ignored it.

---

Re: I find it a bit silly

Lately Google does things that seem "silly" but seem "right" to them. There are more.

Personally I don't have any way to influence these (Google's) decisions.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

icsterm

  • Newbie
  • *
  • Posts: 6
Re: Version 1.17.0-1306 - notifications not working
« Reply #8 on: October 15, 2018, 12:39:58 pm »
Is there any workaround using other software, such as 3rd party file managers/ringtone apps?
I have root so maybe copying my sound file to /system can fix my issue (make the custom sound a system sound file) (I know rooting is not something normal users will do just to fix this kind of issue).


Edit: Yep, it worked, I copied my mp3 sound to /system/media/audio/notifications and now the issue is non existing :)
« Last Edit: October 15, 2018, 12:50:29 pm by icsterm »

Alfistione

  • Newbie
  • *
  • Posts: 2
Re: Version 1.17.0-1306 - notifications not working
« Reply #9 on: October 18, 2018, 11:20:06 pm »
I have the problem although I chose a system sound. But it's not only the missing sound, but also the vibration doesn't work.

Android 8.1

icsterm

  • Newbie
  • *
  • Posts: 6
Re: Version 1.17.0-1306 - notifications not working
« Reply #10 on: October 19, 2018, 07:48:04 pm »
Since last update no sound is working, custom or system, notification appears but without sound AND vibration.

Why??? I can't tell what is the issue now :-\ Previous build launched one week ago (the one for 20% of play accounts) worked fine with system sounds.
« Last Edit: October 19, 2018, 08:02:54 pm by icsterm »

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: Version 1.17.0-1306 - notifications not working
« Reply #11 on: October 20, 2018, 12:25:14 pm »
On Xiaomi phones with MIUI -

- the only sound that works at this time is if in Aqua Mail you select "default notification sound".

Any other sound (custom sound file, or any other built-in notification sound) will not play.

This has to do with 1) changes that Google is forcing all app developers to make 2) a certain something that's different and wrong in MIUI.

We were able to reproduce, looking at workarounds.

For now please be sure to select "default notification sound" in Aqua Mail (and you can change what that default sound is in Phone Settings).

Regarding vibration - our QA was not able to reproduce the issue with that.

Would be best to contact support / aqua-mail dot com - they have a Xiaomi with MIUI over there (I don't).
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: Version 1.17.0-1306 - notifications not working
« Reply #12 on: October 22, 2018, 05:28:54 pm »
We just posted a fix for "any built-in notification sound on Xiaomi with MIUI" here:

https://www.aqua-mail.com/forum/index.php?topic=6887.0

Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

vista

  • Newbie
  • *
  • Posts: 1
Re: Version 1.17.0-1306 - notifications not working
« Reply #13 on: October 28, 2018, 01:17:51 pm »
Hi,
I like this app, but I have no notifications as well. Tried every setting possibility..
Would appreciate a solution very much!
Thank you   Uli

mikeone

  • Hero Member
  • *****
  • Posts: 2762
Re: Version 1.17.0-1306 - notifications not working
« Reply #14 on: October 28, 2018, 01:34:46 pm »
Hi,
I like this app, but I have no notifications as well. Tried every setting possibility..
Would appreciate a solution very much!
Thank you   Uli
Which phone, which Android version, which AquaMail version?