Author Topic: There is delay time when launching app with enabled fingerprint  (Read 3899 times)

phubinh13

  • Newbie
  • *
  • Posts: 4
When I setup Aqua with enabled fingerprint then Aqua always is delayed about 2-3 seconds before showing screen to scan fingerprint. This issue happens after I upgrade from Android 7 to Android 8.

Device testing:
Samsung Galaxy S8+
Android 8 official with device.
Aqua Mail- Paid: 1.14.2-840

Sent from my SM-G955U using Tapatalk

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: There is delay time when launching app with enabled fingerprint
« Reply #1 on: April 10, 2018, 10:18:02 pm »
We don't add any artificial delays :) maybe the fingerprinting code in Android takes longer to initialize?

https://www.reddit.com/r/GalaxyS8/comments/7xynmu/s8_plus_oreo_update_has_made_my_fingerprint/

???

The opinions there vary (it's slower for two users, faster for one other) - and one opinion / experience that "redoing the fingerprint" made it faster.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

phubinh13

  • Newbie
  • *
  • Posts: 4
Re: There is delay time when launching app with enabled fingerprint
« Reply #2 on: April 11, 2018, 01:54:30 pm »
I don't think so because with any app as Dropbox, Box,... There is no delay time.

Sent from my SM-G955U using Tapatalk


Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: There is delay time when launching app with enabled fingerprint
« Reply #3 on: April 13, 2018, 10:06:53 pm »
OK I'll file a bug and ask the developer who worked on this feature to investigate.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

phred

  • Sr. Member
  • ****
  • Posts: 384
Re: There is delay time when launching app with enabled fingerprint
« Reply #4 on: April 14, 2018, 05:23:44 am »
Where exactly is the option to enable fingerprint detection for AM?

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: There is delay time when launching app with enabled fingerprint
« Reply #5 on: April 15, 2018, 01:48:33 pm »
App settings -> security
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

phred

  • Sr. Member
  • ****
  • Posts: 384
Re: There is delay time when launching app with enabled fingerprint
« Reply #6 on: April 15, 2018, 06:04:58 pm »
App settings -> security
Thanks!
I can't count how many times I looked for 'security' and didn't see it. I'm probably suffering from feature overload. (And that's not a bad thing.)

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: There is delay time when launching app with enabled fingerprint
« Reply #7 on: April 17, 2018, 07:46:36 pm »
OK we worked out the cause of the delay and have a fix / workaround - will be included in next 1.15 build.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

phubinh13

  • Newbie
  • *
  • Posts: 4
Re: There is delay time when launching app with enabled fingerprint
« Reply #8 on: April 19, 2018, 08:37:46 am »
OK we worked out the cause of the delay and have a fix / workaround - will be included in next 1.15 build.
Thanks for fixing quickly.

Sent from my SM-G955U using Tapatalk


Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: There is delay time when launching app with enabled fingerprint
« Reply #9 on: April 20, 2018, 07:58:56 pm »
The fix is present in the current "official beta":

https://play.google.com/apps/testing/org.kman.AquaMail
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

phubinh13

  • Newbie
  • *
  • Posts: 4
Re: There is delay time when launching app with enabled fingerprint
« Reply #10 on: April 23, 2018, 03:52:07 pm »
The fix is present in the current "official beta":

newbielink:https://play.google.com/apps/testing/org.kman.AquaMail [nonactive]
This issue is fixed after installing new beta build

Sent from my SM-G955U using Tapatalk