Author Topic: Push Mail for Exchange  (Read 6113 times)

weasterling

  • Newbie
  • *
  • Posts: 2
Push Mail for Exchange
« on: January 28, 2017, 12:34:08 am »
I saw that this feature was added in December but after enabling it in settings it worked for about a day and now my exchange account only updates with the scheduled sync. Any help is appreciated!

mikeone

  • Hero Member
  • *****
  • Posts: 2746
Re: Push Mail for Exchange
« Reply #1 on: January 28, 2017, 12:54:50 am »
I saw that this feature was added in December but after enabling it in settings it worked for about a day and now my exchange account only updates with the scheduled sync. Any help is appreciated!
Which AquaMail version are you using?

mikeone

  • Hero Member
  • *****
  • Posts: 2746
Re: Push Mail for Exchange
« Reply #2 on: January 28, 2017, 01:03:55 am »
« Last Edit: January 28, 2017, 01:13:54 am by mikeone »

weasterling

  • Newbie
  • *
  • Posts: 2
Re: Push Mail for Exchange
« Reply #3 on: January 28, 2017, 01:17:53 am »
I have the latest release on the play store and after reading this post: https://www.aqua-mail.com/forum/index.php?topic=5240.15.  I realized that because i am a bit of a flashoholic the token ID probably got messed up by restoring the app via TB. After uninstalling and reinstalling push seems to be working for now. Thanks for your quick response!

mikeone

  • Hero Member
  • *****
  • Posts: 2746
Re: Push Mail for Exchange
« Reply #4 on: January 28, 2017, 01:18:36 am »
One more thing could be worth to try:

Quote
This is somewhat of a mystery.  I started the debugging and noticed that push seemed to be working.  The only thing that I changed is that I had uploaded the newest development version 1.8.0-112, set analytics to off and started debugging.   Push seems to be working now with debugging set to off.  I will continue to monitor and send a log if push stops.

Like I say, it is somewhat of a mystery, but if it is working, that is all good.

Maybe your IT dept has removed the blocking.

Maybe installing a newer Aqua Mail version "fixed" the previously broken GCM (the app asks Google Play Services to regenerate its device token ID when it detects that it's been updated... and I've seen those tokens go bad, push messages not delivered).

Anyway, glad to hear about the improvement.
« Last Edit: January 28, 2017, 01:20:41 am by mikeone »

mikeone

  • Hero Member
  • *****
  • Posts: 2746
Re: Push Mail for Exchange
« Reply #5 on: January 28, 2017, 01:25:45 am »
I have the latest release on the play store and after reading this post: https://www.aqua-mail.com/forum/index.php?topic=5240.15.  I realized that because i am a bit of a flashoholic the token ID probably got messed up by restoring the app via TB. After uninstalling and reinstalling push seems to be working for now. Thanks for your quick response!
Glad to hear that you could solve this issue.