Author Topic: Latest build deletes mail from server!!  (Read 8232 times)

Trailerman

  • Newbie
  • *
  • Posts: 10
Latest build deletes mail from server!!
« on: January 03, 2016, 05:39:00 pm »
Hi

I have just lost a load of mail and was not sure how this had happened.  Mail appeared on my mobile device and was deleted, as all accounts had been set up not to delete on the server (ie. mail deleted in Aquamail was setup NOT to be deleted on the server, so I would still receive it on my desktop client).

Having deleted mail in Aquamail, when I then came to check my mail on my desktop client (Outlook) no email was received.  It had been deleted from my mail server.

I then ran some tests, and sure enough, when I delete mail on my phone in Aquamail, it no longer arrives at my desktop client!   I presume this is because Aquamail is now deleting it at the server.  I presume also that this is something which the latest build has inadvertently implemented.   I have changed no settings in Aquamail since I originally set it up, with all my accounts set to delete mail in Aquamail but NOT on the server). 

This is a big deal as I have now lost a load of mail.  Please could you ensure the issue is fixed and patched ASAP.

Many thanks

Jules
« Last Edit: January 03, 2016, 05:44:28 pm by Trailerman »

mikeone

  • Hero Member
  • *****
  • Posts: 2762
Re: Latest build deletes mail from server!!
« Reply #1 on: January 03, 2016, 06:28:23 pm »
Please have a look into the FAQ page:

http://www.aqua-mail.com/?page_id=227

Search for (it's item #3l:
How can I delete messages in AquaMail without deleting them from the server?

Each account has a setting for the default way to delete messages. The initial setting is “move to deleted first, delete from server when purging the deleted folder”.

To change the default: long press the account in the main screen and choose “Options and Folders”, then “Account options”.

Tap “Deleting messages” and choose “Hide in the app, keep on the server”.
« Last Edit: January 03, 2016, 06:30:50 pm by mikeone »

StR

  • Hero Member
  • *****
  • Posts: 1558
Re: Latest build deletes mail from server!!
« Reply #2 on: January 03, 2016, 06:42:12 pm »
It would be helpful if you provide more information: Aquamail version; what type of connection (account)  you are using: IMAP, POP3, EWS; provider (gmail?...?).
Also, when you are saying that it was set up not to delete mail on server, what specific option(s)  are you talking about?
That will help Kostya to figure out what is going on with your setup.

Trailerman

  • Newbie
  • *
  • Posts: 10
Re: Latest build deletes mail from server!!
« Reply #3 on: January 04, 2016, 11:50:50 am »
Hi

... and thanks for your responses.  I'll try and provide more information in the hope it helps to resolve the issue:

1.  I am using Aquamail version 1.6.0.6
2.  Mail protocol for incoming mail is IMAP
3.  Provider is 1 and 1 (mail host, domain and web host)

In terms of settings, I have a feeling the 'Deleting Messages' option in Account Options may have changed slightly since I set it up (I could be wrong here as I only have the current version to check).   

When I checked my settings yesterday, all accounts were set to 'Move to Deleted folder first'.   I have not changed this option since I originally set the phone and Aquamail up in September of last year.   Since then, message deleted on the phone (using the trash can) have never previously been deleted on the server, and have therefore still arrived at my desktop client (Outlook).  In the last few days, I noticed that mail I deleted on the phone was no longer arriving at my desktop client.  When I tested this, sure enough if I deleted mail on the phone, it was deleted on the server.

I am now testing the 'Hide in the app, keep on the server' setting, to see if this works better.   However, I don't want to just hide the emails, I want to delete them in Aquamail, but not on the server. 

Has this option or it's implementation changed in a recent version?   I have not changed any settings, so I can only assume that something has changed in the app.

Thanks again for your help.

Jules

StR

  • Hero Member
  • *****
  • Posts: 1558
Re: Latest build deletes mail from server!!
« Reply #4 on: January 04, 2016, 12:15:35 pm »
I don't think anything about these options  has changed  in the recent versions, but I will leave this to Kostya to say authoritatively.

Is it possible that's something has changed on the server? E.g. if you enabled immediate deletion of messages in the web interface (as described on the page linked below ) that could have the effect you described. https://help.1and1.com/e-mail-and-office-c37589/webmail-c75820/troubleshooting-c85106/permanently-remove-deleted-e-mails-in-1and1-webmail-a748725.html

Trailerman

  • Newbie
  • *
  • Posts: 10
Re: Latest build deletes mail from server!!
« Reply #5 on: January 04, 2016, 12:56:13 pm »
Hi

I appreciate your help and suggestions, but nothing has changed on the server or in the way my mail service functions (at least not by me).

Hopefully Kostya can shed some light.  In the meantime, am I correct in thinking that the 3rd setting is the safest in terms of keeping mail on the server?

Incidentally, the first option here just says "Move to deleted folder first" and not “move to deleted first, delete from server when purging the deleted folder”, so perhaps something has changed.

Jules

StR

  • Hero Member
  • *****
  • Posts: 1558
Re: Latest build deletes mail from server!!
« Reply #6 on: January 04, 2016, 05:55:10 pm »
Incidentally, the first option here just says "Move to deleted folder first" and not “move to deleted first, delete from server when purging the deleted folder”, so perhaps something has changed.

That's how the option has been for many months. Mikeone simply described the meaning of that option for you.

Trailerman

  • Newbie
  • *
  • Posts: 10
Re: Latest build deletes mail from server!!
« Reply #7 on: January 04, 2016, 06:47:10 pm »
Understood.

StR

  • Hero Member
  • *****
  • Posts: 1558
Re: Latest build deletes mail from server!!
« Reply #8 on: January 04, 2016, 07:18:44 pm »
Hopefully Kostya can shed some light.  In the meantime, am I correct in thinking that the 3rd setting is the safest in terms of keeping mail on the server?

Yes, "hide in Aquamail" essentially means "Delete it from view in Aquamail, but don't do anything with it on the server" (not even move it to the "Deleted" folder).

mikeone

  • Hero Member
  • *****
  • Posts: 2762
Re: Latest build deletes mail from server!!
« Reply #9 on: January 04, 2016, 07:52:13 pm »
Hi,
Please look also into this thread:

"IMAP configuration, seems to be DELETING some messages from server"

http://www.aqua-mail.com/forum/index.php?topic=3501.msg17227#msg17227

Quote
If you "hide" messages, then they're stored on the Android device for a limited time and then deleted (to avoid infinite storage growth), only from the Android device, not the mail server. This is automatic.

Trailerman

  • Newbie
  • *
  • Posts: 10
Re: Latest build deletes mail from server!!
« Reply #10 on: January 05, 2016, 10:51:20 am »
Many thanks Mikeone.

I guess for now I'll keep using the 'Hide' option for deleting messages.

I'm still unclear on why things started behaving differently (and would still be grateful for any feedback or suggestions from Kostya), but I guess sometimes these things just happen.

Thanks again.

Jules

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: Latest build deletes mail from server!!
« Reply #11 on: January 05, 2016, 02:43:38 pm »
Re: That's how the option has been for many months. Mikeone simply described the meaning of that option for you.

For many *years*

Re: I'm still unclear on why things started behaving differently

Not to my knowledge.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

Trailerman

  • Newbie
  • *
  • Posts: 10
Re: Latest build deletes mail from server!!
« Reply #12 on: January 08, 2016, 02:35:43 pm »
Thanks Kostya

Can you perhaps just clarify what happens when I am using the Smart Folder (which is where I check all my mail) and use the recycle bin icon (which is how I delete all my unwanted mail)?

Does this apply the delete message settings specific to each account, or does it use a different method for deleting email?

When I delete mail from the Smart folder, they do not appear in the 'Deleted' folder for the account in question.   Does this mean it's 'hiding' them somewhere else (I have the account in question set to 'Hide' deleted messages because I can't afford to lose any more), or does it delete them on the server?

Many thanks for your help.

Jules

Trailerman

  • Newbie
  • *
  • Posts: 10
Re: Latest build deletes mail from server!!
« Reply #13 on: January 08, 2016, 05:52:34 pm »
As I mentioned in my post, I have the account set to 'Hide' deleted emails.   Do they appear in the deleted folder or not?  If not, where do they go?

Trailerman

  • Newbie
  • *
  • Posts: 10
Re: Latest build deletes mail from server!!
« Reply #14 on: January 11, 2016, 11:37:06 am »
Thanks Paris Geek - all clear.