Author Topic: No background checking when on 3G - seems to work fine on wifi  (Read 3031 times)

paul1966

  • Newbie
  • *
  • Posts: 2
I have been using AquaMail for some time and love it.  I recently upgraded my Samsung GS3 to a GS6 (Lollipop) on the Sprint network.  Very seamless back up and restore BTW - Thank You!

Everything seemed to be working fine - probably because I was on Wifi.  I get off wifi and on 3G and aqua mail will not check email when it's in the background.  When it's in the foreground - even when the phone display goes to sleep - it checks email fine and gives me notifications.

I've been all over the forum and tried many of the suggestions but to no avail.

I've attached a log file where I started the log then put Aqua Mail in the background for a while - no email fetched - then went back into it - and viola - it went and fetched email.  Hopefully you will be able to see what's happening - or what's not happening in this case.   :)

Any help you can provide that might point me in the right direction would be extremely appreciated.  Thank you.

Paul

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: No background checking when on 3G - seems to work fine on wifi
« Reply #1 on: May 27, 2015, 11:41:14 pm »
Thank you for the log.

First, your mobile operator is too happy to disconnect the app's network connections. Sometimes they do that (an "optimization").

Since you're using push mail, the app notes those errors, and retries, but only a limited number of times.

I would recommend restricting push mail to WiFi only (and so the app will do scheduled checks) in app settings under "mail, receiving", however:

Second, the app is also failing on initial connects to all your mail servers -- and every time it happens during SSL negotiation (not initial socket connect).

Don't know why there is any difference vs. when app is in foreground -- but this makes me think of Android's "restrict background data" (in system settings under Data usage) or perhaps a battery saving app (third party or built-in).

And to reiterate -- the app is trying to do what it's supposed to do, but its network connections are disconnecting or not establishing at all.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

paul1966

  • Newbie
  • *
  • Posts: 2
Re: No background checking when on 3G - seems to work fine on wifi
« Reply #2 on: June 02, 2015, 12:01:51 am »
Thank you for your response and sorry for the delay in responding to your response.

It does indeed look like a Sprint (US) / GS6 issue that is being worked out.  (I would post a link to the thread here but I'm not allowed)

I applied the update and changed all the recommended settings.  Unfortunately this has only marginally improved the issue for me.  I Didn't have any issues like this with my old phone so I'm hopeful they will get this worked out soon.

Thanks again for looking into this.

Paul

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: No background checking when on 3G - seems to work fine on wifi
« Reply #3 on: June 02, 2015, 01:30:37 am »
Thank you for the information that this is a known issue and your mobile operator is aware of it.

--

PS - as for links, sorry, spam control... for a new user, it takes a few messages before the board would let you post links...
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/