Author Topic: Connection error on mobile network  (Read 3333 times)

LD Jackson

  • Newbie
  • *
  • Posts: 14
Connection error on mobile network
« on: May 14, 2015, 02:38:23 am »
I can't pinpoint exactly when this started, but AquaMail will no longer connect and receive emails on my mobile network. As soon as I connect to a WiFi network, it starts working. I have doubled checked my settings and can find nothing changed. As a test, I installed K9 and set it up exactly as AquaMail is set up and it works perfectly.

My phone is a Samsung s5 running Android 5.

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12742
Re: Connection error on mobile network
« Reply #1 on: May 14, 2015, 10:56:16 pm »
Can you try rebooting the phone?

If it doesn't help, can you capture the issue in the app's debug log (please see my signature below)?

Oh, it's not a Gmail account, is it?

Set up with "OAUTH" (Google's "more secure" authentication method -- used if you choose "Gmail or Google Apps" account type in Aqua)?

I've seen OAUTH fail on mobile data sometimes -- and that's something "inside" Google Play Services, not AquaMail itself... And then K9 doesn't support OAUTH.

If that's the case, you can re-create the account as "Internet mail" (not "Gmail / Google Apps"), and the app won't use OAUTH for authentication.
« Last Edit: May 14, 2015, 11:16:31 pm by Kostya Vasilyev, Aqua Mail »
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

LD Jackson

  • Newbie
  • *
  • Posts: 14
Re: Connection error on mobile network
« Reply #2 on: May 15, 2015, 12:58:46 am »
I actually tried removing the app and reinstalling. That seemed to have fixed the issue last night, but it was back again this morning. I was then browsing through the account setup dialog and changed the authentication from "Strict" to "Accept Any". So far, that seems to have taken care of the problem. Not sure why that would prevent the connection from working on the mobile network, but it obviously was the culprit.

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12742
Re: Connection error on mobile network
« Reply #3 on: May 15, 2015, 01:04:14 am »
Perhaps your mobile operator is replacing SSL certificates on the fly -- "spying" on your encrypted traffic, really.

May seem strange or out of the question, but that is what it seems like, based on your experience.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/