Author Topic: IMAP configuration, seems to be DELETING some messages from server  (Read 3522 times)

harekrishna

  • Newbie
  • *
  • Posts: 45
Hi

I have Aquamail (love it!) on my Samsung Note4.

Using IMAP configuration.

Working great, EXCEPT that some times when I delete a message from the phone . . . . BEFORE that same message has been retrieved and downloaded onto my desktop computer (where I also need to read it), the message will apparently get DELETED from the email server.

The result is that message NEVER is retrieved from the Windows 7 desktop computer (using Outlook 2007).

WHAT I NEED:   

(a) All messages are retrieved for reading on my desktop computer  (regardless if already read on the phone via Aquamail).

(b) Deleting a message in Aquamail will NOT delete a message from email server, and will NOT "mark" the message as already downloaded from server (or words to that effect)

Can anybody help me?

Thanks

StR

  • Hero Member
  • *****
  • Posts: 1558
Re: IMAP configuration, seems to be DELETING some messages from server
« Reply #1 on: April 28, 2015, 07:29:38 am »
I think the closest to what you want would be to "hide messages in aquamail", instead of deleting.
For that, in the top most screen ( accounts view), long touch on the account in question,  "options and folders" -> "account  options" -> "deleting messages" -> the last of the 3 options "hide in the app, keep on the server".


harekrishna

  • Newbie
  • *
  • Posts: 45
Re: IMAP configuration, seems to be DELETING some messages from server
« Reply #2 on: April 28, 2015, 12:54:22 pm »
Thanks so much for your reply!

I would never have found that setting without your help.

I've changed it as you've suggested.


QUESTION:   When will all the messages I have read (on the phone) and deleted (on the phone) . . .. actually get DELETED (from the phone)?    Should I change a setting to make sure they do get 'purged' regularly, so I don't end up with thousands of old deleted messages (on the phone)?


Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: IMAP configuration, seems to be DELETING some messages from server
« Reply #3 on: April 28, 2015, 01:16:16 pm »
If you "hide" messages, then they're stored on the Android device for a limited time and then deleted (to avoid infinite storage growth), only from the Android device, not the mail server. This is automatic.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/