Author Topic: Emails not properly synchronized with IMAP  (Read 14998 times)

Neutral

  • Newbie
  • *
  • Posts: 12
Emails not properly synchronized with IMAP
« on: April 28, 2014, 01:40:02 pm »
Hi,
I use Aquamail for a while now, and ther are two issues that drive me crazy almost every day...
The first one is that some messages are not properly synchronized.
Explanations :
I have several email accounts, well configured with IMAP in my Android 4.2 terminal (Galaxy S4).
I also read/write emails from other terminals (laptop at home for the most but at work also) that's why I use IMAP to keep my accounts up to date on every terminal.
But when I have read and deleted some messages from my laptop (for example), these messages sometimes (not always...) still remain in my phone, in the incoming folder and as unread... :-/

This issue does not appear with the native email client and with the same account configuration.

The second issue is that I have often many login errors during synchronization (authentication errors) although the accounts are obviously well configured (as it works most of the times, but not always). I have then to manually force a second sync and generally it works then.
I have not this kind of issue with the native email client with the same account configuration...

Thanks forward if anyone can help me solve these two boring issues  ;)

Edit : I forgot to precise that I have the licensed (pro) version of Aquamail
And sorry for my imperfect English which is not my native language   ;)
« Last Edit: April 28, 2014, 01:42:43 pm by Neutral »

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: Emails not properly synchronized with IMAP
« Reply #1 on: May 02, 2014, 12:28:43 am »
Hello,

Please try updating to latest development build (here on the forum) -- there were some fixes where push mail could end up monitoring the wrong folder.

On login errors, it would help me to know what the exact messages were, and what mail service this is.

In particular, GMail has a server side limit on the number of push connections, counting all apps on all devices. Trying to exceed these limits will cause a login error, and my app is very honest about reporting errors.

This is documented in the FAQ, just search the page for "gmail".

Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

Neutral

  • Newbie
  • *
  • Posts: 12
Re: Emails not properly synchronized with IMAP
« Reply #2 on: May 21, 2014, 04:36:51 pm »
Thanks for your reply  :)
Actually I have always the same error message. The message is partially in French, regarding my terminal conf.
"Erreur d'identification (login) avec le server entrant : BAD internal server error" which I could translate in English by "Login error with incoming server".
I don't remember to have ever noticed this error with my Gmail account. It happens daily with any of my other email accounts (with the French provider "Free"). The IMAP server connection is secured by SSL.
I just opened Aquamail to check, and you can just state what I'm talking about...  :(



Regarding the problem of bad synchronization of the IMAP folders, I ended up with deleting the accounts and recreating them (which is the pain in the a** to entirely retrieve my customized parameters  :-\)
Things seem to be in order now.

So it would be nice if I could solve the IMAP connection issues because this drives me crazy  :o
« Last Edit: May 21, 2014, 04:52:54 pm by Neutral »

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: Emails not properly synchronized with IMAP
« Reply #3 on: May 21, 2014, 11:03:33 pm »
The "internal server error" message comes from the server. Aqua just shows it.

The message really speaks for itself -- I recommend contacting your email provider.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

Neutral

  • Newbie
  • *
  • Posts: 12
Re: Emails not properly synchronized with IMAP
« Reply #4 on: May 22, 2014, 09:36:34 am »
Hummm... It's not worth trying to contact them, I know they won't have any suitable answer to this...  :-\
Is there no way to turn this notification off kin Aqua ? So that we don't get these ugly red error messages in the mail accounts list anymore...

Neutral

  • Newbie
  • *
  • Posts: 12
Re: Emails not properly synchronized with IMAP
« Reply #5 on: May 22, 2014, 01:16:38 pm »
Well, I said 2 posts ago that the IMAP folders synchronization seemed to work well, indeed it doesn't  :-[
Still some messages that remain in my inbox and as unread in Aqua although they have been deleted from the server.
I checked with Thunderbird on my laptop and the webmail which are both up to date, so only Aquamail differs from the server state.
So I guess my provider is not involved in that particular issue  ;)

Notice : I installed yesterday the 1.26.33 dev build of Aquamail

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: Emails not properly synchronized with IMAP
« Reply #6 on: May 22, 2014, 11:56:36 pm »
Are the two accounts in question getting those auth errors?

Aqua does not "invent" those errors, you know.

Something you could try is change the IMAP authentication method -- some mail servers "advertise" CRAM-MD5 for sending login / password, but it doesn't really work (e.g. telefonica.es).

Long press the account -> account setup -> Manual.

You'll be looking at incoming server settings.

Change "authentication" from "Choose automatically" to "Prefer compatibility" -- press Next to try and validate.

If it works and you don't get login errors, this means the server's CRAM-MD5 is broken.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

Neutral

  • Newbie
  • *
  • Posts: 12
Re: Emails not properly synchronized with IMAP
« Reply #7 on: May 23, 2014, 12:04:28 am »
Thanks for the tip.
Actually Ialready tried the compatibility mode, but it didn't change anything.
I ended up today bay deactivating SSL, that seem to solve the problem (should I say obviously ?), although it isn't the fairest solution...  :-\

Any idea for the leftover messages in AM inbox although they were deleted from the (IMAP) server by another client ?  ???

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12740
Re: Emails not properly synchronized with IMAP
« Reply #8 on: May 23, 2014, 12:25:39 am »
Re: leftover messages:

Long press the account -> options and folders -> account options -> enable "remove deleted".
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

Neutral

  • Newbie
  • *
  • Posts: 12
Re: Emails not properly synchronized with IMAP
« Reply #9 on: May 23, 2014, 12:58:21 am »
Hummm... I'm not sure to figure out if this tip is exactly supposed to do  ???
Is this function a sort of "patch" to correct some update issue of the inbox folder ?
Just to be sure I was clear enough : I don't talk about deleted message that are in the trash, but I talk about some messages that are still in the Inbox folder and with the unread status, although I have read and sent then to the trash folder from my laptop email client.

Neutral

  • Newbie
  • *
  • Posts: 12
Re: Emails not properly synchronized with IMAP
« Reply #10 on: May 23, 2014, 01:31:02 am »
Salut Paris Geek  ;)

Yes of course my laptop email client (Thunderbird) is configured with IMAP for all my accounts. Same in Aquamail.
Sorry I currently have no more undesired message in my inbox to show you right now, but next time I get the issue I will take a screenshot  ;)

Neutral

  • Newbie
  • *
  • Posts: 12
Re: Emails not properly synchronized with IMAP
« Reply #11 on: May 23, 2014, 11:53:45 am »
Not so long to wait for the issue to show again...  ;)
Two messages arrived this morning in one of my accounts. Read within Aquamail first, then deleted from the webmail later, and the 2 messages remain in AM despite forcing manual update resync.
On the left the account list with the timestamps of sync, in the middle the inbox shown in Aquamail with the 2 messages that shouldn't be there, and on the right the inbox seen from the webmail :

[nofollow]

The account is configured with IMAP :

[nofollow]

Neutral

  • Newbie
  • *
  • Posts: 12
Re: Emails not properly synchronized with IMAP
« Reply #12 on: May 23, 2014, 01:24:45 pm »
Following you screenshots:

1/ In "Free", AquaMail trash folder, do you see the deleted messages? (assuming that your trash folder is correctly synchronized with server)

Yes, the 2 messages are duplicated in the 2 folders inbox and trash in Aquamail.

Quote
2/ Using Zimbra, go to "Free" trash folder, and tell me please if the two deleleted messages are still there. If yes, delete them, and then synchronize AquaMail to check.

Yes they are still in the trash.
I have deleted them from the trash as requested (in Zimbra) and resync Aquamail, the 2 messages are still in both inbox and trash folders in AM !  :-\

Quote
Using myself Free/AquaMail (but not Zimbra on smartphone) - and receiving many spams - I hope that together we will eventually find a solution to this issue...

Rgds
Should I understand that you experience also some strange AM behavior like I do ?  :o

Neutral

  • Newbie
  • *
  • Posts: 12
Re: Emails not properly synchronized with IMAP
« Reply #13 on: May 23, 2014, 10:21:18 pm »
Well, it seem that I can reproduce the issue every time I delete a message from outside Aquamail  ???

I chose a set of 3 messages I wanted to delete and went through the steps you were asking for.
Here are the screenshots for every step :

[nofollow]



Neutral

  • Newbie
  • *
  • Posts: 12
Re: Emails not properly synchronized with IMAP
« Reply #14 on: May 24, 2014, 01:14:58 am »
OK I understand what you mean  :)
But actually I don't uderstand the purpose of this option as it just brings Aquamial to work exactly as expected with an IMAP conf (assuming every client should mirror the server state)  ???
I'm going to adjust the settings, I'll come back to give my feedback  ;)
Thanks for your help !  :D
« Last Edit: May 24, 2014, 01:26:06 pm by Neutral »