Author Topic: *** Solved *** problems searching for emails after moving to outlook.com  (Read 4779 times)

dbsse

  • Newbie
  • *
  • Posts: 3
Hi guys
Over the weekend I decided to stop using gmail.
I set up a new outlook account and imported 16000 gmail emails.

I then set up the outlook account in AquaMail.

However when I try to search for an email it get "No messages"

Any ideas?

Thanks
« Last Edit: April 23, 2014, 01:15:24 am by dbsse »

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12742
Re: problems searching for emails after moving to outlook.com
« Reply #1 on: April 21, 2014, 02:57:01 pm »
The preset for Outlook.com in AquaMail is POP3, which does not support server side search.

Did you do Manual account setup, with IMAP? The settings are posted around here somewhere.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

mikeone

  • Hero Member
  • *****
  • Posts: 2746
Re: problems searching for emails after moving to outlook.com
« Reply #2 on: April 21, 2014, 04:53:41 pm »
Big thanks to @Al who shared this news.

Incoming IMAP
Server: imap-mail.outlook.com
Server port: 993
Encryption: SSL

Outgoing SMTP
Server: smtp-mail.outlook.com
Server port: 587
Encryption:  TLS

Source: http://blogs.office.com/b/microsoft-outlook/archive/2013/09/12/outlook-com-now-with-imap.aspx

I ran a quick test, ran into one server bug (for which my workaround code kicked in and was able to push through), but overall it seems to work.

Not switching the app's preset for Hotmail to IMAP just yet, want to give it a bit of time just in case.

Anyone who would like to try it out can do so by creating a new account in AquaMail using Manual setup mode and entering the settings listed above.

@dbsse
Welcome in the AquaMail forum :-)
Hope this will be of help to solve your issue.
« Last Edit: April 21, 2014, 07:51:23 pm by mikeone »

dbsse

  • Newbie
  • *
  • Posts: 3
Re: problems searching for emails after moving to outlook.com
« Reply #3 on: April 21, 2014, 09:24:56 pm »
Hi.
Thanks for the help. Have configured the outlook account to use IMAP.
Still the same problem. And if it does find an email it only shows only the first one it comes across.

Didn't have this problem with the gmail. But as I said I have stopped use it.

Thanks

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12742
Re: problems searching for emails after moving to outlook.com
« Reply #4 on: April 22, 2014, 12:01:54 am »
Ok, I just tried adding my @hotmail account with IMAP, and tried a server side search -- worked for me, although I only have a few dozen messages.

So, given this, would you record a debug log, capturing the issue? Give it some time to actually run server side search, and I'll need "raw session data" enabled in log settings as well.

For instructions, please see my signature, below.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

dbsse

  • Newbie
  • *
  • Posts: 3
Solution from Kostya

Quote
Looks like you're initiating search from the main window -- which searches all accounts / folders at once, but only messages already loaded into the app.

To search older messages, including those never seen by the app -- server side search, in other words -- please initiate search from a folder's message list.

On a tablet, in two panel layout mode, this would be the search icon in the bottom-right icon bar -- below the respective folder's message list.quote]