Author Topic: 1.3.0-pre8  (Read 12467 times)

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12742
Re: 1.3.0-pre8
« Reply #15 on: December 21, 2013, 11:32:24 pm »
@beaky - not sure what you meant by "with a forward, I was expecting.." -- this was a draft started by another mail app and pulled down via IMAP....

So you were not "forwarding" the message, you were editing a draft. I expect that the CC and BCC were filled in for the same reason, from the draft you started in Thunderbird.

As for the new content area being "half a screen large" -- well, it should grow as you type more, are you saying it didn't?

Feel free to send a screenshot to kmansoft / at sign / gmail / dot com, though.
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

beaky

  • Full Member
  • ***
  • Posts: 169
Re: 1.3.0-pre8
« Reply #16 on: December 22, 2013, 06:23:13 am »
@beaky - not sure what you meant by "with a forward, I was expecting.." -- this was a draft started by another mail app and pulled down via IMAP....

So you were not "forwarding" the message, you were editing a draft. I expect that the CC and BCC were filled in for the same reason, from the draft you started in Thunderbird.

As for the new content area being "half a screen large" -- well, it should grow as you type more, are you saying it didn't?

Feel free to send a screenshot to kmansoft / at sign / gmail / dot com, though.

In a lot of cases the screen is divided initially about 40% from the top by a thin blue line.
What is below the line is either a message i am replying to, or a message I am forwarding, or it is empty.
"My" message is in the top portion, which does indeed grow as the message is typed.
What was different in this case was that my original message was below the line instead of above it.
I tried a few specific cases A,B,C below, and in case (D) I have tried to describe what happened with the email sent originally from thunderbird. The other cases, particularly A and B, are cases where I reedit a saved draft, created on AM itself.

Here is the situation:
A: Editing a previously edited draft, which was not itself a reply to an earlier message:
1 what I previously saved is in the top area of the screen, and the cursor goes to the start.
2 to, cc, and subject are filled in with the original values.
3 although there is a blue line across the screen about 40% or more from the top, there is nothing below the line.
Exactly what I expected

B: Editing a previously edited draft that IS a reply to another message
1 same as case A above
2 same as case A above
3 below the line is the email I was replying to, with an "include" check box.
Exactly what I expected

C: Forwarding a message, that had attachments:
1 a dialogue pops up asking me to select the attachments to include.
2 the top half of the screen above the blue line is empty, cursor at the top left.
3 the bottom half below the blue line holds the email text of the old message I am forwarding
4 in the top half, the to: box is initially empty, but the subject is the original subject prepended with "Fwd:"
Again what I expected.

D: In the case of the message that I had "sent" using thunderbird:
(This had been an original message with attachments, but not a reply or a forward)
1: top portion of screen above the blue line is blank (here is where I expected my 'draft' to be)
2: my original message is below the blue line. (As if I was forwarding or replying to it)
3: subject line is original subject (as expected)
4: to and cc at the top were filled in.(as expected)
5: there is a dialogue to allow me to choose what attachments to include, like case C. (Not sure if this is what I expected, but it is logical).

What is unexpected in case D is that although in almost every respect it matches case A, reediting a previous draft, the difference is that the preexisting text is below the thin blue line.
Indeed, that seems to be the significant difference, that the original message I wrote is below instead of above the thin blue line.

Kostya Vasilyev

  • Hero Member
  • *****
  • Posts: 12742
Re: 1.3.0-pre8
« Reply #17 on: December 22, 2013, 04:05:03 pm »
Regarding case D:

As I explained many, many times before...

I don't have a full-featured HTML editor at my disposal that can be used with arbitrary HTML code downloaded from a server side draft.

Checking if the HTML is "special" or not, and showing existing draft content in the top or the bottom area would be inconsistent from one message to the next, and cause a lot of head-scratching (and support emails).

The app asks you to pick attachments because it doesn't have them, they're also coming from the server... and maybe the users is in a slow mobile data area and doesn't need them all.
« Last Edit: December 22, 2013, 04:14:14 pm by Kostya Vasilyev, Aqua Mail »
Creating debug logs for diagnostics: https://www.aqua-mail.com/troubleshooting/

The official FAQ: https://www.aqua-mail.com/faq/

Лог-файлы для диагностики: https://www.aqua-mail.com/ru/troubleshooting/

Вопросы и ответы: https://www.aqua-mail.com/ru/faq/

beaky

  • Full Member
  • ***
  • Posts: 169
Re: 1.3.0-pre8
« Reply #18 on: December 22, 2013, 11:45:32 pm »
Regarding case D:

As I explained many, many times before...

I don't have a full-featured HTML editor at my disposal that can be used with arbitrary HTML code downloaded from a server side draft.

Checking if the HTML is "special" or not, and showing existing draft content in the top or the bottom area would be inconsistent from one message to the next, and cause a lot of head-scratching (and support emails).

The app asks you to pick attachments because it doesn't have them, they're also coming from the server... and maybe the users is in a slow mobile data area and doesn't need them all.
I must look to my Thunderbird set up, as my intention has always been to send plain text only with that. I need to check and if necessary change that.
I had not linked the "HTML editor" issue with what I found,but I should have done.
Thanks.

beaky

  • Full Member
  • ***
  • Posts: 169
Re: 1.3.0-pre8
« Reply #19 on: December 23, 2013, 09:11:49 pm »
I have now checked and the addressees received the message twice, once with the added text, once without. Both are now in the sent folder.
I must learn to be more observant.....
As I had sent the first iteration at about 2am, and it was apparently not in the sent folder by after lunch the next day, I surmised that some oddity (maintenance, say) at the mail server meant it stayed in the outbox all that time, and I was unwittingly editing an outbox item, not a draft.
I did not look for or notice anything that would tell me it was outbox and not draft.
Even that does not stack up as this surely should have resulted in only one message.
I have obviously mistaken some element of this; done something when I thought I had done something quite different. That makes any "problem" impossible to analyse.

A puzzle so rare and full of possibilities to be a series of mistakes and coincidences, I am not going to worry about it further.