AquaMail Forum

English => Bug reports => Topic started by: godd on November 13, 2016, 05:31:31 am

Title: Aqua Mail used 68% of my battery today
Post by: godd on November 13, 2016, 05:31:31 am
 :o
I recall some time ago Kostya explained some possible battery drain by some bugs in Android 5. Is there any cure to this problem? 68% is extreme. I do not use push, have 2 Google  accounts and one Yahoo, pull every 30 min I guess. 
Title: Re: Aqua Mail used 68% of my battery today
Post by: StR on November 13, 2016, 11:19:30 am
Is there something wrong with the math in the screenshot?  It adds up to well over 100%! How is that possible?  What is taken as 100%?:

I just checked, on my phone those numbers constitute the percentage of the total usage since the phone was unplugged (notofthe battery capacity) .
The fact that it doesn't add up is still an indication of wrong counting. So, all that information is suspect.

But in general,  if you have nothing else running, what's wrong with Aquamail using the most of juice?
Title: Re: Aqua Mail used 68% of my battery today
Post by: Kostya Vasilyev on November 13, 2016, 04:54:50 pm
Re: total, all apps > 100%

https://code.google.com/p/android/issues/detail?id=80131

Maybe they went too far in fixing this bug?

Or maybe it's a different manifestation of same bug?

Re: AquaMail's %%

If you're still seeing those numbers (i.e. have not reset by charging), please tap into Aqua Mail (to see a breakdown of its battery usage) and let me know:

- "Total awake" time there
- "Mobile radio active" (or "Total connect") time

It would be interesting to also check these specifics for the other apps in your screenshot:

Google Services, Android OS, Textra..

..because if you(we) are going to trust the 68% reported for Aqua Mail, then, logically, you(we) should trust the (almost) just as outrageous %% for those other apps / services.

Title: Re: Aqua Mail used 68% of my battery today
Post by: godd on November 17, 2016, 05:18:44 pm
Grabbed a couple  more screenshots. Did not see such big numbers anymore, but even 21% hardly can be considered normal I guess.
Title: Re: Aqua Mail used 68% of my battery today
Post by: Kostya Vasilyev on November 18, 2016, 10:42:41 pm
Yep, it's the famous "mobile radio active" bug.

Your detailed AquaMail screenshot (thank you) has for AquaMail:

- A perfectly reasonable "keep awake" time, 16 min, this is how long, total, the app actually worked in the background and kept the device awake

- A totally out of proportion "Total connection" time (how Samsung labeled "Mobile radio active"), this is Android keeping the phone's radio in a high power state long after it's needed, and attributing it to some random app (in your case, AquaMail)

The bug is random. May not happen, may happen with any app.

For screenshots of other apps, including Google's own, please see the FAQ:

http://www.aqua-mail.com/?page_id=227

under Android 5+ and high battery use, 'mobile radio active'

The Google bug report:

https://code.google.com/p/android/issues/detail?id=165558

Reported: Apr 14, 2015
Priority: Small
4115 people starred this issue